# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?s:
<ins
(?:(?!</ins>).)*?
"adsbygoogle"
.*?
</ins>)
"""
test_str = (" 0\n"
"down vote\n"
"favorite\n"
" \n\n"
"I have a thousand html pages (without admin panel) with codes of adsense. And I want to remove all of them from html. One code looks like:\n\n"
"<ins class=\"adsbygoogle\"\n"
" style=\"display:inline-block;width:160px;height:600px\"\n"
" data-ad-client=\"ca-pub-7165746718333100\"\n"
" data-ad-slot=\"9087512399\"></ins>\n\n"
"Another:\n\n"
"<ins class=\"adsbygoogle\"\n"
" style=\"display:inline-block;width:160px;height:600px\"\n"
" data-ad-client=\"ca-pub-7163746711373100\"\n"
" data-ad-slot=\"7467236139\"></ins>\n\n"
"All of them are similar but not equal. A tried to write regex to find and replace it with empty string, but unsuccessfully.\n\n"
"Any suggetion how to do it automatically?\n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.