// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)(?s:
<ins
(?:(?!</ins>).)*?
"adsbygoogle"
.*?
</ins>)"#).unwrap();
let string = " 0
down vote
favorite
I have a thousand html pages (without admin panel) with codes of adsense. And I want to remove all of them from html. One code looks like:
<ins class=\"adsbygoogle\"
style=\"display:inline-block;width:160px;height:600px\"
data-ad-client=\"ca-pub-7165746718333100\"
data-ad-slot=\"9087512399\"></ins>
Another:
<ins class=\"adsbygoogle\"
style=\"display:inline-block;width:160px;height:600px\"
data-ad-client=\"ca-pub-7163746711373100\"
data-ad-slot=\"7467236139\"></ins>
All of them are similar but not equal. A tried to write regex to find and replace it with empty string, but unsuccessfully.
Any suggetion how to do it automatically?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}