using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=\*[^\s*=]*|=[^\s*=]*\*|=[~*]?|!=|\(\)|[<>]=?";
string input = @"=~, =*,=,!=...etc.
=ijnhu9*
=1$n*
=*bfrg%1
=*7lk;y";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}