re = /=\*[^\s*=]*|=[^\s*=]*\*|=[~*]?|!=|\(\)|[<>]=?/m
str = '=~, =*,=,!=...etc.
=ijnhu9*
=1$n*
=*bfrg%1
=*7lk;y'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end