package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)=\*[^\s*=]*|=[^\s*=]*\*|=[~*]?|!=|\(\)|[<>]=?`)
var str = `=~, =*,=,!=...etc.
=ijnhu9*
=1$n*
=*bfrg%1
=*7lk;y`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}