import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/|www\\.)\\S+\\.\\w+$";
final String string = "https://www.website.com\n"
+ "http://www.website.com\n"
+ "http://website.com\n"
+ "http://www.com\n"
+ "www.website.com\n"
+ "https://website\n"
+ "http://.com\n"
+ "website.com\n"
+ "invalid\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}