// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(https?:\/\/|www\.)\S+\.\w+$").unwrap();
let string = "https://www.website.com
http://www.website.com
http://website.com
http://www.com
www.website.com
https://website
http://.com
website.com
invalid
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}