re = /^(https?:\/\/|www\.)\S+\.\w+$/m
str = 'https://www.website.com
http://www.website.com
http://website.com
http://www.com
www.website.com
https://website
http://.com
website.com
invalid
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end