#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\\*\"Bearer\s*[A-Za-z0-9._-]*\\*\""
Local $sString = ",\\\"authorization\\\":\\\"Bearer xxxxxx.yyyyy.fff-dddd\\\","
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")