re = /\\*\"Bearer\s*[A-Za-z0-9._-]*\\*\"/
str = ',\\\\\\"authorization\\\\\\":\\\\\\"Bearer xxxxxx.yyyyy.fff-dddd\\\\\\",'
# Print the match result
str.match(re) do |match|
puts match.to_s
end