using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\*\""Bearer\s*[A-Za-z0-9._-]*\\*\""";
string input = @",\\\""authorization\\\"":\\\""Bearer xxxxxx.yyyyy.fff-dddd\\\"",";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}