import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)(?:\\(\\s?(\\d+)\\))?(\\.[^.]*)?$";
final String string = "filename(10)\n"
+ "filename\n"
+ "filename(10)(0)\n"
+ "file.name.ext\n"
+ ".ext\n"
+ ".ext(10)\n"
+ "file.name(10).ext\n"
+ "file.name(10)(0).ext\n"
+ "file.ext\n"
+ "file.name(10)\n"
+ "file.name(10)(0)\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}