re = /^(.*?)(?:\(\s?(\d+)\))?(\.[^.]*)?$/m
str = 'filename(10)
filename
filename(10)(0)
file.name.ext
.ext
.ext(10)
file.name(10).ext
file.name(10)(0).ext
file.ext
file.name(10)
file.name(10)(0)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end