import re
regex = re.compile(r"^(.*?)(?:\(\s?(\d+)\))?(\.[^.]*)?$", flags=re.MULTILINE)
test_str = ("filename(10)\n"
"filename\n"
"filename(10)(0)\n"
"file.name.ext\n"
".ext\n"
".ext(10)\n"
"file.name(10).ext\n"
"file.name(10)(0).ext\n"
"file.ext\n"
"file.name(10)\n"
"file.name(10)(0)\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")