const regex = /\bclass(?:Name)*\s*=\s*([\"\']([_a-zA-Z0-9\s\-\:]+)[\"\'])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bclass(?:Name)*\\s*=\\s*([\\"\\\']([_a-zA-Z0-9\\s\\-\\:]+)[\\"\\\'])', '')
const str = `class="flex w-full md:w-4/12 justify-center items-center mb-4 sm:mb-6"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}