$re = '/\bclass(?:Name)*\s*=\s*([\"\']([_a-zA-Z0-9\s\-\:]+)[\"\'])/';
$str = 'class="flex w-full md:w-4/12 justify-center items-center mb-4 sm:mb-6"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);