re = /\bclass(?:Name)*\s*=\s*([\"\']([_a-zA-Z0-9\s\-\:]+)[\"\'])/
str = 'class="flex w-full md:w-4/12 justify-center items-center mb-4 sm:mb-6"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end