const regex = /\b(\d+)(?: \1){3,}\b|\b(\d+)(?: \2){2}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)(?: \\1){3,}\\b|\\b(\\d+)(?: \\2){2}\\b', 'gm')
const str = `I am 42 42 4 hey yoo
I am 42 42 42 hey yoo
I am 42 42 42 4 hey yoo',
I am 42 42 42 42 hey yoo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}