re = /\b(\d+)(?: \1){3,}\b|\b(\d+)(?: \2){2}\b/m
str = 'I am 42 42 4 hey yoo
I am 42 42 42 hey yoo
I am 42 42 42 4 hey yoo\',
I am 42 42 42 42 hey yoo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end