using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*([a-zA-Z_]+)\s*=\s*(""?)([^""]*?)\2\s*[;#]";
string input = @"Name= ""Value"" ;Comment
Name=Value ;Comment";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}