re = /\S*([a-zA-Z_]+)\s*=\s*("?)([^"]*?)\2\s*[;#]/
str = 'Name= "Value" ;Comment
Name=Value ;Comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end