$re = '/\S*([a-zA-Z_]+)\s*=\s*("?)([^"]*?)\2\s*[;#]/';
$str = 'Name= "Value" ;Comment
Name=Value ;Comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);