using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\=+(?=(?:(?:[^""]*""){2})*[^""]*$)(?=(?:(?:[^']*'){2})*[^']*$)(?=(?:(?:[^`]*`){2})*[^`]*$)";
string input = @"foo=""bar=foo""
foo='bar=foo'
foo=`bar=foo`";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}