$re = '/\=+(?=(?:(?:[^"]*"){2})*[^"]*$)(?=(?:(?:[^\']*\'){2})*[^\']*$)(?=(?:(?:[^`]*`){2})*[^`]*$)/m';
$str = 'foo="bar=foo"
foo=\'bar=foo\'
foo=`bar=foo`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);