re = /\=+(?=(?:(?:[^"]*"){2})*[^"]*$)(?=(?:(?:[^']*'){2})*[^']*$)(?=(?:(?:[^`]*`){2})*[^`]*$)/m
str = 'foo="bar=foo"
foo=\'bar=foo\'
foo=`bar=foo`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end