$re = '/(?<=class=").*?(?=">)/m';
$str = '<tajweed class="ham_wasl">ٱ foo</tajweed>
<tajweed class="madd">ٱ bar</tajweed>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);