re = /(?<=class=").*?(?=">)/m
str = '<tajweed class="ham_wasl">ٱ foo</tajweed>
<tajweed class="madd">ٱ bar</tajweed>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end