import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\s\\t-])test(?=[\\s\\.\\t])";
final String string = "This is a test.\n"
+ "The testing was good.\n"
+ "The tester was bad.\n"
+ "package.test.com\n"
+ "skkg@test.com\n"
+ "Regex-test-is tough\n"
+ ""rm/_HOST@DEV.HADOOP.R1-CORE.R1.TEST.NET"\n"
+ "/Users/dattem/Desktop/DevCenter/test/ssl/\n"
+ "The test is today.\n"
+ "Name -test one";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}