const regex = /(?<=[\s\t-])test(?=[\s\.\t])/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\s\\t-])test(?=[\\s\\.\\t])', 'gi')
const str = `This is a test.
The testing was good.
The tester was bad.
package.test.com
skkg@test.com
Regex-test-is tough
"rm/_HOST@DEV.HADOOP.R1-CORE.R1.TEST.NET"
/Users/dattem/Desktop/DevCenter/test/ssl/
The test is today.
Name -test one`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}