re = /(?<=[\s\t-])test(?=[\s\.\t])/i
str = 'This is a test.
The testing was good.
The tester was bad.
package.test.com
skkg@test.com
Regex-test-is tough
"rm/_HOST@DEV.HADOOP.R1-CORE.R1.TEST.NET"
/Users/dattem/Desktop/DevCenter/test/ssl/
The test is today.
Name -test one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end