package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\\m\s+((?:\w+\s+)*\w+):\s*(.*)`)
var str = `\m Character name: message
\m Sample: message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}