re = /^\\m\s+((?:\w+\s+)*\w+):\s*(.*)/m
str = '\\m Character name: message
\\m Sample: message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end