package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\s*(.*?)\s*\}`)
var str = `
my {test} value
my { test } value
my { test } value
my { test hello I am } value
my { testing 10 times } value
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}