$re = '/\{\s*(.*?)\s*\}/m';
$str = '
my {test} value
my { test } value
my { test } value
my { test hello I am } value
my { testing 10 times } value
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);