re = /\{\s*(.*?)\s*\}/m
str = '
my {test} value
my { test } value
my { test } value
my { test hello I am } value
my { testing 10 times } value
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end