#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m), .*"
Local $sString = "Example Johner Gladstone Pinot Noir 2015, 75CL" & @CRLF & _
"Stella Artois Premium Lager Bottle, 1 X 660 Ml" & @CRLF & _
"Pepesza Ppsh-40 Vodka Tommy Gun, 1 L"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")