using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"C\((\w+)[^[]*\[T\.([^]]+)\]";
string input = @"C(State)[T.Kansas]
C(State, Treatment('Alaska'))[T.Kansas]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}