$re = '/C\((\w+)[^[]*\[T\.([^]]+)\]/m';
$str = 'C(State)[T.Kansas]
C(State, Treatment(\'Alaska\'))[T.Kansas]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);