package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)C\((\w+)[^[]*\[T\.([^]]+)\]`)
var str = `C(State)[T.Kansas]
C(State, Treatment('Alaska'))[T.Kansas]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}