using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"flyheight.com\/videos\/([a-z0-9]+)";
string input = @"https://flyheight.com/videos/ybb347
https://flyheight.com/videos/yb24os
https://flyheight.com/public/images/videos/793f77362f321e62c32659c3ab00952d.png
https://flyheight.com/videos/5o6t98/#disqus_thread
https://flyheight.com/videos/yb24os
https://flyheight.com/videos/ybb347";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}