const regex = /flyheight.com\/videos\/([a-z0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('flyheight.com\\\/videos\\\/([a-z0-9]+)', 'gm')
const str = `https://flyheight.com/videos/ybb347
https://flyheight.com/videos/yb24os
https://flyheight.com/public/images/videos/793f77362f321e62c32659c3ab00952d.png
https://flyheight.com/videos/5o6t98/#disqus_thread
https://flyheight.com/videos/yb24os
https://flyheight.com/videos/ybb347`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}