$re = '/flyheight.com\/videos\/([a-z0-9]+)/m';
$str = 'https://flyheight.com/videos/ybb347
https://flyheight.com/videos/yb24os
https://flyheight.com/public/images/videos/793f77362f321e62c32659c3ab00952d.png
https://flyheight.com/videos/5o6t98/#disqus_thread
https://flyheight.com/videos/yb24os
https://flyheight.com/videos/ybb347';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);