import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[.* Spoilers\\])?[^\\[\\]\\n]+$";
final String string = "[No Spoilers] Here's The Title\n"
+ "[S2 Act 2 Spoilers] Here's The Title\n"
+ "[S2 Act 7 Spoilers] Here's The Title\n"
+ "[S7 Act 7 Spoilers] Here's The Title\n"
+ "Here's The Title\n"
+ "Here's The Title [No Spoilers]\n"
+ "[Invalid Spoilers] Here's The Title\n"
+ "[S7 Act 7] Here's The Title";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}