$re = '/^(\[.* Spoilers\])?[^\[\]\n]+$/m';
$str = '[No Spoilers] Here\'s The Title
[S2 Act 2 Spoilers] Here\'s The Title
[S2 Act 7 Spoilers] Here\'s The Title
[S7 Act 7 Spoilers] Here\'s The Title
Here\'s The Title
Here\'s The Title [No Spoilers]
[Invalid Spoilers] Here\'s The Title
[S7 Act 7] Here\'s The Title';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);