use strict;
my $str = '[No Spoilers] Here\'s The Title
[S2 Act 2 Spoilers] Here\'s The Title
[S2 Act 7 Spoilers] Here\'s The Title
[S7 Act 7 Spoilers] Here\'s The Title
Here\'s The Title
Here\'s The Title [No Spoilers]
[Invalid Spoilers] Here\'s The Title
[S7 Act 7] Here\'s The Title';
my $regex = qr/^(\[.* Spoilers\])?[^\[\]\n]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}