import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n{3,}";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, \n"
+ "sed do eiusmod tempor incididunt ut labore et dolore magna \n"
+ "Tincidunt nunc pulvinar sapien et ligula ullamcorper \n"
+ "malesuada proin libero. Sit amet risus nullam eget.\n\n\n\n\n"
+ "Purus gravida quis blandit turpis cursus in hac. Felis \n"
+ "bibendum ut tristique et egestas. Curabitur vitae nunc sed \n"
+ "vitae nunc sed velit. Nunc faucibus a pellentesque sit amet \n"
+ "porttitor eget dolor.";
final String subst = "\\n\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}