$re = '/\n{3,}/m';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit,
sed do eiusmod tempor incididunt ut labore et dolore magna
Tincidunt nunc pulvinar sapien et ligula ullamcorper
malesuada proin libero. Sit amet risus nullam eget.
Purus gravida quis blandit turpis cursus in hac. Felis
bibendum ut tristique et egestas. Curabitur vitae nunc sed
vitae nunc sed velit. Nunc faucibus a pellentesque sit amet
porttitor eget dolor.';
$subst = "\n\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;