using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h2.*?>(.*?)<\/h2>";
string input = @"<h2 id=""h2-1"">H2 Heading (1)</h2>
<p>Lorem ipsum dolor sit amet consectetur ...</p>
<h3 id=""h3-1"">H3 Heading</h3>
<h2 id=""h2-2"">H2 Heading (2)</h2>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}