import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h2.*?>(.*?)<\\/h2>";
final String string = "<h2 id=\"h2-1\">H2 Heading (1)</h2>\n"
+ "<p>Lorem ipsum dolor sit amet consectetur ...</p>\n"
+ "<h3 id=\"h3-1\">H3 Heading</h3>\n"
+ "<h2 id=\"h2-2\">H2 Heading (2)</h2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}