package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<h2.*?>(.*?)<\/h2>`)
var str = `<h2 id="h2-1">H2 Heading (1)</h2>
<p>Lorem ipsum dolor sit amet consectetur ...</p>
<h3 id="h3-1">H3 Heading</h3>
<h2 id="h2-2">H2 Heading (2)</h2>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}